Can I play a music or video file?


#21

@bltzr and @jcelerier I talk too much, but the bottom line is -
when do you guys think I can have a working version of score?
if you are in vacation I dont want to stress you, but I just need to know if its an option for the project.
Thank you


#22

so, yeah, definitely, that should do it for you, jumping to any place in the timeline has been implemented recently (I just double-checked and it works), so that should do the trick


#23

I have Score score-2.0.0-a3-win64.exe version working on a win10 pc. In this machine I’ve never installed score before, neither jack.
Is it possible that the problem I have in other computer its generated by the previous installation of Jack, or Score-2.0.0-a1-win64.exe version (registry modification for example)? Both was uninstalled before to instal 2.0.0-a3 version.


#24

what do you think, @jcelerier ?

@Ofersmi would you be able to test what @Serdna suggests and tell us if it helps ?


#25

@bltzr I can only do it later tonight. Just to understand fully @Serdna you suggest I uninstall both Jack and score and reinstall?


#26

That’s what I did in the a3 version laptop that doesn´t worked.

I’ve been installed version 3 in a clean laptop and is working properly (with some bugs), but I haven’t been able to do the same in another laptop in wich there was instaled a v1.0.0-b41 version with Jack.


#27

so @Serdna what you want me to do is to find a laptop that score or jack was never installed before?


#28

@ofersmi Those are the characteristics of the laptop that score a3 works for me.
Tomorrow I will try to check it again with another one.


#29

@Serdna and @bltzr I will try to find one, but Its abit hard the next couple of days im in rehearsals…


#30

Hmm, something fishy must be going on : I tried on a clean windows 10 virtual machine and couldn’t get a crash with 2.0.0a3. ASIO is indeed missing, I’ll update the binary (it seems my portaudio version wasn’t built with ASIO, sorry).


#31

I fixed it so that ASIO will be available with portaudio now: https://github.com/OSSIA/score/releases/download/v2.0.0-a3/score-v2.0.0-a3-win64.exe


#32

Hi @jcelerier, could you please try to install this version: https://github.com/OSSIA/score/releases/tag/v2.0.0-a1 with Jack in a clean machine?. If it doesn’t work, unninstall both an install a3 version.
Today I made some test in the office:
2 clean Pc win10—> Installing first Score a3, works
1 clean Pc win10—> I installed 2.0.0-a1 version with Jack,run jack but score doesn’t run. Then I uninstall both, I installed 2.0.0-a3 vers and crash at start
1 clean pc win10—> I installed 2.0.0a1 with Jack, I run jack, and score a1 works perfectly. Uninstalled jack and Score a1, I installed a3 score vers and works ok
I don´t know why, but at least what I see, if the a1 version with jack crash, any
later version (I´ve only tested .exe version) that support audio should crash.


#33

Welcome @jcelerier!
Maybe there is something I dont understand: I installed the latest version you sent, and now I see ASIO is there, I select ASIO4ALL (I dont have my real sound card with me)m I drop an audio file on the timeline, play. and now I expect to hear sound, shouldnt I ?


#34

just making sure you selected the sound card in score’s preferences
and if you did, you need to turn off and on the main audio switch (in the menu bar)
does that help ?


#35

@bltzr Yes to both, I have selected in settings, and the audio is on by default. BUT, I managed to have sound now. I think the problem is in the way I add the file, just drag and drop doesnt link it to an audio device and even if I do so manually (pressing the little circle next to the audio file name and type in the address of the device) still it doesnt read it (when I press play the top of the file doesnt turn green like any other element on the timeline). but if I drop the audio device on the timeline and add a process (with the little plus on the blue line) I can add a Sound file and then give it a path on the disk, and the it works!
Same problem with midi files, I drop then on the timeline select the output to an existing midi device, but the dont play… so I must be doing something wrong.


#36

yes, I know, but I had to turn it off, wait a while, and then on in order to hear anything

I also had this happening sometimes

Well, it’s still in (quite recent) alpha, so chances are that those are nifty bugs.

I hope you can work your way around those bugs to use score for your project. :crossed_fingers:

Cheers!


#37

I think I can find a way, it will be good to have a clear list of actions to get al time intervals to play…


#38

I managed to reproduce crashes when switching of audio back-end on windows, so here is a version that hopefully fixes your crashes : https://ufile.io/jkgdj


#39

sorry the UI for outputing midi data is absolutely not clear as of now, I’ll try to improve it soon.


#40

Hey @jcelerier I had today a talk with @bltzr and he explained many many things that I have gotten wrong, I now have a much clearer Idea of score and its methods. So I am diving in!
I will for sure have more questions on the way but for now it’s all very clear.
During our conversation I have showed him some bugs and I will post those as issues on the git.