Re-triggering an interval

I have a question about trigger behaviour. If a trigger fires, and the interval it’s attached to plays, is it possible to ‘reset’ the interval so that it can be triggered again? So far as I can tell it’s only possible to play a given interval once until the transport is reset. The interactive loop behaviour shown at the bottom of the loop tutorial page ( ) is close to what I have in mind. In my case, I’m imagining more of a one-shot behaviour, so that when the trigger is fired, the interval (and any subsequent connected intervals) plays to the end, and then waits for another trigger.

My use case here is that I’d like to be able to send messages from Max to Score in order to trigger a chain of events (like a mini-composition within Score), and I’d like to be able to trigger such chains more then once without resetting the transport.

Hi @emontpellier !

you can do that by not attaching the trigger to the beginning
then it can be triggered as many times as you want (which puts it “offtime”, so to say)


that also work with several “chained” intervals


does that help ?

Hey @bltzr, thanks for the reply! I’m having trouble reproducing the behaviour you demonstrate. When I try creating a trigger on a state, it won’t trigger at all when I click on it:


I tried switching the trigger from its default mode (False) to Pulse, and attaching a parameter from an OSSIA device hosted in Max to the trigger. In this case, neither bangs from Max nor clicks on the trigger icon seem to work.


I think I must be missing something… I’m on testing on Score 2.0.0-a3, OS X 10.11.6, Max 7.3.5. ossia-max 1.0.0

OK, so that seems to depend on the way you create the first state. Doing ass you do (I’m assuming you’re double-clicking) I get the same as you.

Creating the first state with the create tool (or the plus button), then deleting the previous interval makes it work. Does it for you too ?


(sorry, had to split the gif in 2 because of its weight)

Afraid not. Using this method in Score 1.0.0, I was able to trigger the interval once, but not to re-trigger it.


In Score 2.0.0, I’m still not able to trigger it at all.


Hmmm well I’m not sure at all what’s going on here… @jcelerier do you have any idea?

that’s really really strange !

I’ve tried again, with a built-from-source version and with 2.0b3 from github, and it works (repeatedly) on both. @jcelerier also tried and had no problem

I even noticed that it works when creating the first state by double-clicking, I don’t know how I failed the first time, but maybe that’s a track to follow ???

by any chance, do you have a Mac with a more recent OS handy ? 10.11 is the only difference I see here…

Huh, weird indeed. I’ll have access to one with 10.13 later today, will report back ASAP.

Just tested with Score 1.0.0 and 2.0.0-a3 on macOS 10.13.4, and getting exactly the same behaviour that I reported previously. Apart from the case where I linked the trigger to an ossia.parameter in Max, these are all freshly-created triggers, i.e. I haven’t modified the conditionals or touched any other settings. I’ve tried plain left-clicking, or clicking with shift, Cmd, Opt and Ctrl - no joy. Let me know if there’s anything I can test over here.

that’s very strange, I don’t know what to say, sorry :confused:

I did a bit more testing on the 10.11 machine. In Score 2.0.0-a3, I’m able to re-trigger the interval by setting the trigger’s condition to Pulse and sending it bangs from an ossia.parameter in Max (clicking on the trigger icon still doesn’t work, though):


Testing in Score 1.0.0 yields behaviour similar to what I was getting from it before - sending a message from Max will trigger the interval, but it won’t re-trigger it.


Does it at least work for “normal” triggers connected to prior elements ?

Like this? I’m afraid not:


My guess is that there are two problems here:

  • re-triggering has apparently been implemented in 2.0 (just tried), so it’s normal that it doesn’t work in 1.0.

  • there seems to be a problem happening on your side with the triggers’ detection of clicks. Are you using some special mouse / trackpad / whatever ?

Negative, just the built-in trackpad. The 10.11 machine is a 2015 Macbook Pro, and the 10.13 one is a Macbook Pro bought new from the Apple store about two weeks ago. I’ll check on a few more machines here…

could you try with a mouse, then ? you never know…

Just tested with a mouse on the 10.11 machine and it works! I guess it’s specific to trackpad clicks, then?

it works with my trackpad, I guess we now need to investigate the trackpad settings, then

After checking on the 10.13 machine and seeing that the mouse/trackpad weren’t working there, I figured out that it’s actually the same problem as my other post - the clock source just needed to be switched from Default to Dataflow. Once that’s done, both trackpad and mouse work fine. Phew!

Hahaha ! So that definitely calls for action on the clock selection default!

Thanks for investigating, @emontpellier!