Ossia crashing when used in m4l


#1

i just found out about this great project, but sadly since i started to implement ossia into one of my patches it crashes as soon as i try to load it in live.
when i start with a new blank patch max crashes each time i want to open a ossia help file. no matter which one.
something seems very wrong…
when i start max as standalone i get none of this problems

(i tried the bundled max version and the newest version from cycling74.com)

hope that someone can help me as i really would benefit from this system!


#2

hello ! are you on macos or windows ?


#3

macOS 10.12.6
max 8.02 + ive tried Lives last official, beta and alpha release, all with the same result
(just updated from .5 today in hope that this would solve the problem)


#4

okay, I’ll try to investigate this as soon as possible (we had problem with M4L previously, I thought they were solved but apparently not !)


#5

thanks a lot!
it would make life so much easier for me
:+1:


#6

Hi !
I just tried to check what could go wrong with this but it’s ok on my side :

I also tried a few help patches (ossia, ossia.parameter) and they seemed to work correctly too.

here’s the ossia max package I used, can you replace the content of the ossia release with this one ? Maybe it’s a bug which has been fixed since the last release : https://ufile.io/1jhoq


#7

(it’s a debug build, it will be fairly slower than the release build but if it crashes with this one we will get better error logs).


#8

thx! will try that as soon as possible


#9

looks good, so far… :slight_smile: thx again


#10

Great, I’ll make a release in a few days