Unable to play default blank scenario in Score 2.1.1 on OSX 10.14


#1

Hi,

Trying to see what I can do with Score by following the documentation.

Stuck in https://ossia.github.io/score/first_steps/time_approach/index.html#let-the-time-flow

When opening Score, user gets provided a blank scenario and its default time source. When clicking the play button (or pressing spacebar key), time will start flowing along the top timeline.

I am unable to play the blank scenario. Pressing space or clicking play does activate the button, but no playhead appears and nothing happens.

Seems like I am missing something obvious, but according to the docs it should be as easy as that.

Running Score 2.1.1 (also tried 2.1.0) on OSX 10.14.3.

Any hints?

Taavi


#2

For others having the same problem:

Setting the Audio driver to “Dummy (No audio)” in preferences gets the time flowing.

Not very obvious though, especially since I am not planning to use any audio. I see this might be connected to “Clock source” which is set to the only available option “Audio”.

Taavi


#3

Hi Taavi,

That is it, if you do not wish to use audio, the “dummy” driver is probably the option for you.
Otherwise, the scenario execution will fail if the clock source isn’t synchronized with your audio configuration (sample rate mismatch between Jack and score for example).

I Anny case, even without audio, you’ll always have to make sure the “On” button is lit.
scoreOn


#4

Hi,

The ‘On’ button was lit and the ‘Dummy’ driver is the only possible option in the audio driver selection, but it was not selected by default.

In any case, it is working now, but was not working ‘out of the box’.

Best,
Taavi


#5

This seems to be related to this reported issue
It only accrues on first start up.

Flowing releases (and previous like v2.0.0-a25) will support actual audio drivers if you ever wish to use it, so keep an eye out for them.